Squiz Connect Performance Issues

Incident Report for Squiz

Resolved

We are no longer seeing issues with Connect, and performance has returned to the usual level.
Please get in touch via My.Squiz.Net to let us know if you have any issues you believe are related.

We will also provide a post mortem for this incident in the next few days.
Posted Jul 21, 2025 - 20:21 AEST

Investigating

We are currently experiencing issues with connect functionality and are experiencing delays in processing and starting executions.

Please bear with us while we investigate the issue.
Posted Jul 21, 2025 - 19:52 AEST
This incident affected: Squiz SaaS Hosted Instances.