Connect Performance Degradation

Incident Report for Squiz

Resolved

The maintenance has now concluded and we do not expect any further outages at this time.
Posted Mar 26, 2025 - 03:00 AEDT

Update

Our service provider has provided the following details of the US & EMEA outage, we expect similar behaviour during the AU maintenance window.

During maintenance, all integration flows were temporarily suspended and resumed after the completion of the upgrades to process all received data. The user interface (frontend) was disabled ensuring a smooth transition and minimal disruption of services.
Posted Mar 25, 2025 - 21:22 AEDT

Monitoring

Squiz teams are currently monitoring for any outages caused.
Posted Mar 25, 2025 - 21:03 AEDT

Investigating

Some customers may see a degradation of performance with connect flows.

This is due to a third party provider carrying out essential maintenance.

US and EMEA clients service is now performing as normal, as maintenance in this region is complete.

AU maintenance will be taking place during the following window.

AU Tenant Window:
Start: 1:00 PM GMT
End: 4:00 PM GMT
Posted Mar 25, 2025 - 21:02 AEDT
This incident affected: Squiz SaaS Hosted Instances.