Funnelback UK - Degradation of service

Incident Report for Squiz

Resolved

This incident has been resolved. Information pertaining to this incident will be available via this status page in the near future.
Posted Sep 11, 2026 - 00:29 AEST

Monitoring

A fix has implemented and we are monitoring results
Posted Sep 10, 2026 - 22:35 AEST

Update

Teams are continuing to investigate the cause of this slowness.
Posted Sep 10, 2026 - 22:05 AEST

Investigating

We are currently seeing performance issues on for UK based Funnelback clients. Our technical teams are currently investigating the issue.
Posted Sep 10, 2026 - 21:26 AEST
This incident affected: Search (Funnelback).