Squiz Support Number (Australia) - 17 October 2022
Incident Report for Squiz
Resolved
Investigations performed have indicated an issue with our external provider. A workaround has been implemented and conducted tests are successful. Our support staff is able to receive calls via the Squiz (Australia) support number +61 1300 077 849 .

Squiz infrastructure team continues to monitor the environment.
Posted Oct 17, 2022 - 18:30 AEDT
Investigating
Dear Customers,

We are experiencing an issue with receiving calls via the Squiz (Australia) support number +61 1300 077 849. Our Infrastructure team is currently investigating this issue.

Work Around
We are reachable via other support numbers (+64) 4 805 0098 from NZ , (+44) 808 267 7849 from UK / Europe , (+1) 877 394 0640 from the US. Alternatively, please reach out to us via MySquiz or via email at support@squiz.net .

We apologise for any inconvenience caused.
Posted Oct 17, 2022 - 17:11 AEDT
This incident affected: Squiz Cloud Hosted Instances.