Global Outage - Cloudflare

Incident Report for Squiz

Resolved

Cloudflare has confirmed that the issue is resolved, and we are also declaring it resolved on our end. For further details, please refer back to this page.
Posted Dec 05, 2025 - 20:36 AEDT

Update

Cloudflare has announced that they have implemented a fixed and we are seeing recovery on all our services.
Posted Dec 05, 2025 - 20:18 AEDT

Monitoring

We are currently experiencing degraded performance for all clients using Cloudflare-backed services
Posted Dec 05, 2025 - 20:17 AEDT
This incident affected: Squiz Cloud Hosted Instances, Squiz SaaS Hosted Instances, and Squiz Funnelback Hosted Instances.