Unable to access Advanced Forms in the Squiz DXP

Incident Report for Squiz

Resolved

The incident has been resolved and Advanced Forms access should be restored for all customers.
Posted Mar 13, 2026 - 12:03 AEDT

Monitoring

A fix has been implemented and we have started to observe recovery. We are monitoring the roll out of the recovery and will confirm that operations are returned to normal once the process has completed.
Posted Mar 13, 2026 - 11:42 AEDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 13, 2026 - 11:15 AEDT

Investigating

Customers are currently experiencing issues with accessing Advanced Forms in the DXP via the Console. Users attempting to access the service are observing HTTP502 errors and/or login forms.

The incident team is currently investigating the cause.
Posted Mar 13, 2026 - 10:50 AEDT
This incident affected: Squiz SaaS Hosted Instances.