Global CDN Outage

Incident Report for Squiz

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 06:50 AEDT

Update

We are continuing to monitor for any further issues.
Posted Nov 19, 2025 - 02:54 AEDT

Monitoring

A fix has been implemented and we are now monitoring the results.
Posted Nov 19, 2025 - 01:47 AEDT

Identified

We are seeing recovery across many sites but we are seeing periodic issues still. We’re monitoring the situation and are in communication with Cloudflare.
Posted Nov 19, 2025 - 01:27 AEDT

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 23:42 AEDT

Investigating

We are currently investigating the issue.
Posted Nov 18, 2025 - 23:13 AEDT
This incident affected: Squiz Cloud Hosted Instances, Squiz SaaS Hosted Instances, Squiz Funnelback Hosted Instances, and Squiz Edge.