Newbury Datacentre Offline

Incident Report for Squiz

Resolved

We can now confirm that performance of the Data Center is now back to a running state.
If you believe you have any issues lingering that are related then feel free to get in contact via My.Squiz.Net.
Posted Jul 22, 2025 - 11:34 AEST

Identified

We are working with our Network provider to work on the issue at hand.
More updates to be posted once we have any more information to share.
Posted Jul 22, 2025 - 11:15 AEST

Update

We are continuing to investigate this issue.
Posted Jul 22, 2025 - 10:43 AEST

Investigating

We have noticed that the Newbury Datacentre in the UK is currently offline.
This may affect Disaster recovery and development instances in the UK region as other parts of our infrastructure will take on the load.

We are currently investigating the cause of the error and will post more updates as this progresses.
Posted Jul 22, 2025 - 10:34 AEST
This incident affected: Squiz Cloud Hosted Instances and Squiz Edge.