Service degradation

Incident Report for Squiz

Postmortem

Executive Summary

On Friday, February 20, 2026, at 1748 UTC, a global Cloudflare incident impacted network routing used to deliver traffic to services hosted on the Squiz DXP platform.

During this time:

  • All DXP users, and Squiz cloud customers using Cloudflare, were unable to log in to any administrative interfaces in the Squiz DXP, including the Console, Content Management System (Matrix), and Funnelback.
  • Customer frontend websites using Cloudflare were returning cloudflare errors “Connection timed Out”

This issue was caused by a change that Cloudflare made to how our network manages IP addresses. Cloudflare have provided a detailed analysis of the incident at https://blog.cloudflare.com/cloudflare-outage-february-20-2026/

Restoration of the cloudflare service for individual customers ranged from between 30 mins to 3.5 hours depending on the IP configurations for each customer.

If you require more information specific to your solution please log a ticket via the My.Squiz portal requesting a Custom Post Incident Report.

Squiz would like to remind customers to subscribe to the Squiz Status page at status.squiz.net to receive real time notification of Major Incidents.

References

Timeline:  20 Feb (UTC)

  • Incident start time: 1749 UTC
  • Squiz Incident declaration: 1800 UTC
  • Initial Squiz Status Page notifications posted: 1809 UTC
  • Cloudflare reported full resolution for anycast customers: 2053 UTC
  • Cloudflare reported full resolution for spectrum customers: 2259 UTC
  • Cloudflare marked the incident resolved on at 23:50 UTC
  • Squiz Declared Incident resolved: 0000 21 Feb UTC
Posted Feb 23, 2026 - 14:56 AEDT

Resolved

This incident has been resolved.
Posted Feb 21, 2026 - 11:00 AEDT

Update

We are still seeing recovery of services at this time and we are continuing to monitoring the situation to ensure all services remain stable.
Posted Feb 21, 2026 - 10:30 AEDT

Update

We are still monitoring this situation at large as well as investigating a handful of remaining intermittent issues. We will provide additional updates as available.
Posted Feb 21, 2026 - 10:02 AEDT

Update

We are seeing recovery of services at this time and we are continuing to monitoring the situation to ensure all services remain stable.
Posted Feb 21, 2026 - 09:33 AEDT

Monitoring

We are seeing recovery of services at this time and we are monitoring the situation to ensure things remain stable.
Posted Feb 21, 2026 - 09:05 AEDT

Update

We are seeing recovery of services at this time and we are monitoring the situation to ensure things remain stable.
Posted Feb 21, 2026 - 09:05 AEDT

Update

We are continuing to work with Cloudflare on full resolution for all affected services. We will provide updates as they become available.
Posted Feb 21, 2026 - 08:54 AEDT

Update

We are continuing to work with Cloudflare on full resolution for all affected services. We will provide updates as they become available.
Posted Feb 21, 2026 - 08:22 AEDT

Update

We are continuing to work with Cloudflare on full resolution for all affected services. We will provide updates as they become available.
Posted Feb 21, 2026 - 08:17 AEDT

Update

We are continuing to work on full resolution and will provide updates as they become available.
Posted Feb 21, 2026 - 07:45 AEDT

Update

We are continuing to work with our content delivery provider for full resolution. We will provide updates as they become available.
Posted Feb 21, 2026 - 07:15 AEDT

Update

We are continuing to work on full resolution with Cloudflare. We will provide further updates as they become available.
Posted Feb 21, 2026 - 06:53 AEDT

Update

We continue to work with Cloudflare regarding the ongoing issues. We will provide further updates as they become available.
Posted Feb 21, 2026 - 06:24 AEDT

Identified

We are working with Cloudflare regarding connectivity issues. The Cloudflare status page can be found here:
https://www.cloudflarestatus.com/incidents/kwy3dt82bwbt
Posted Feb 21, 2026 - 06:03 AEDT

Investigating

We are investigating additional issues for all affected clients. We will provide further updates as they become available.
Posted Feb 21, 2026 - 05:37 AEDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 21, 2026 - 05:30 AEDT

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 21, 2026 - 05:29 AEDT

Investigating

We are currently investigating an issue impacting all our services. Initial diagnostics suggest a widespread disruption with Cloudflare, our content delivery provider. Our team is monitoring the situation closely and will provide updates as they become available.
Posted Feb 21, 2026 - 05:09 AEDT
This incident affected: Squiz SaaS Hosted Instances.