Funnelback UK Service Degradation

Incident Report for Squiz

Resolved

This incident has been resolved
Posted Oct 16, 2025 - 02:54 AEDT

Monitoring

We have identified the source of the issue and have implemented a fix and are currently monitoring the situation
Posted Oct 16, 2025 - 02:46 AEDT

Investigating

We are currently investigating an issue affecting Funnelback services for some customers in our UK datacenter
Posted Oct 16, 2025 - 02:38 AEDT
This incident affected: Squiz SaaS Hosted Instances.