intermediate certificate issues - 15/01/2021
Incident Report for Squiz
Resolved
Squiz has identified and resolved an issue with some SSL certificates in which an intermediate certificate has been revoked by an upstream provider, outside of Squiz control.

This was only affecting some Squiz Clients and as mentioned, only users with Chrome were experiencing issues.
Squiz teams have deployed a fix for affected clients.

If you are still seeing SSL certificate errors in the Chrome browser, please raise a ticket with Squiz Support via the normal channels.
The incident is now resolved. If you have any questions, please contact Squiz Support.
Posted Jan 15, 2021 - 16:02 AEDT
Update
Squiz has identified an issue with some SSL certificates in which an intermediate certificate has been revoked by an upstream provider, outside of Squiz control.

This is only affecting some Squiz Clients and as mentioned, only users with Chrome are experiencing issues.

Squiz teams have deployed a fix for affected clients who use the Squiz Edge CDN.

For affected customers who do not use Squiz Edge our ETR is estimated to be up to 30 minutes as we identify and replace affected certificates.

The next update will be in 30 minutes to StatusPage. If you have any questions, please contact Squiz Support.
Posted Jan 15, 2021 - 15:29 AEDT
Update
Squiz has identified an issue with some SSL certificates in which an intermediate certificate has been revoked by an upstream provider, outside of Squiz control.

This is only affecting some Squiz Clients and as mentioned, only users with Chrome are experiencing issues.

Squiz teams have deployed a fix for affected clients who use the Squiz Edge CDN. The fix is rolling out to our production nodes now and should be fully propagated within 15 minutes.

For affected customers who do not use Squiz Edge our ETR is estimated to be up to 60 minutes as we identify and replace affected certificates.


The next update will be in 30 minutes to StatusPage. If you have any questions, please contact Squiz Support.
Posted Jan 15, 2021 - 15:02 AEDT
Update
Squiz has identified an issue with some SSL certificates in which an intermediate certificate has been revoked by an upstream provider, outside of Squiz control.

This is only affecting some Squiz Clients and as mentioned, only users with Chrome are experiencing issues.

Squiz teams are currently deploying a fix for affected clients who use the Squiz Edge CDN. ETR for affected Edge clients is 45 minutes.

For affected customers who do not use Squiz Edge our ETR is estimated to be up to 90 minutes.

The next update will be in 30 minutes to StatusPage. If you have any questions, please contact Squiz Support.
Posted Jan 15, 2021 - 14:34 AEDT
Update



Squiz has identified an issue with some SSL certificates in which an intermediate certificate has been revoked by an upstream provider, outside of Squiz control. This appears to be only affecting some Chrome users at this stage.

Squiz teams are currently testing a fix before rolling out to affected certificates. ETR is currently unknown.

The next update will be in 15 minutes to StatusPage. If you have any questions, please contact Squiz Support.
Posted Jan 15, 2021 - 14:13 AEDT
Update
Squiz has identified an issue with some SSL certificates in which an intermediate certificate has been revoked by an upstream provider, outside of Squiz control. This appears to be only affecting some Chrome users at this stage.

Squiz teams are currently testing a fix before rolling out to affected certificates. ETR is currently unknown.

The next update will be in 15 minutes to StatusPage. If you have any questions, please contact Squiz Support.


Posted Jan 15, 2021 - 13:56 AEDT
Identified
Squiz has identified an issue with some SSL certificates in which an intermediate certificate has been revoked by an upstream provider, outside of Squiz control. This appears to be only affecting some Chrome users at this stage.

Our Team is working on a fix now.

The next update will be in 15 minutes to StatusPage. If you have any questions, please contact Squiz Support.
Posted Jan 15, 2021 - 13:40 AEDT
This incident affected: Squiz Cloud Hosted Instances.