Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 13, 2025 - 13:00 AEDT
Scheduled
Dear Customer,
SQUIZ wishes to notify you that an emergency maintenance work for EMEA customers will be carried out on DXP CMS (Matrix) that may cause a degradation to your service.
Date: 13 Nov 2025
Maintenance Window Start: 02:00 UTC 13:00 AEDT
Maintenance Window End: 04:00 UTC 15:00 AEDT
Expected Duration: each customer instance may be unavailable for up to 15 minutes
Impact: During the maintenance window, your CMS (Matrix) editor functionality on your CMS (Matrix) application in the non production environment (typically with '-dev' or '-uat' suffix) might not be available and or service degraded. Uncached content may not be available during this time.
Should you have any questions, please contact Squiz Customer Care.
Regards, Squiz Customer Care
Posted Nov 12, 2025 - 16:56 AEDT
This scheduled maintenance affected: Squiz SaaS Hosted Instances.