Support Telephone Line Issues
Incident Report for Squiz
Resolved
We are pleased to inform you that our support phone line has been successfully repaired and is now fully operational.
Posted Sep 06, 2024 - 21:47 AEST
Investigating
Please be advised we are currently experiencing issues with our Support Telephone lines.

This issue is not affecting other services so please continue to contact us via email at support@squiz.net and through MySquiz.

This is only affecting the below phone lines as far as we are aware:

Squiz 24x7 Helpdesk:
(+61) 1300 077 849 from Australia
(+64) 4 805 0098 from New Zealand
(+44) 808 267 7849 from UK / Europe
(+1) 877 394 0640 from the US
Posted Sep 06, 2024 - 19:24 AEST