UK Datacentre Degradation

Incident Report for Squiz

Resolved

This incident has been resolved.
Posted Oct 17, 2025 - 20:02 AEDT

Monitoring

A fix has been implemented and we are monitoring the results
Posted Oct 17, 2025 - 19:54 AEDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 17, 2025 - 19:54 AEDT

Investigating

We are currently investigating an issue with our Squiz Cloud UK DC.
Posted Oct 17, 2025 - 19:49 AEDT
This incident affected: Squiz Cloud Hosted Instances.