Major Incident - ASH and Newbury Data Centre - 01/10/2022
Incident Report for Squiz
Postmortem

Executive Summary

At 20:54 GMT on the 1st of October 2022, Squiz internal monitoring started generating alerts indicating that multiple Squiz Edge customers hosted in our ASH and Newbury Data Centre suffered degradation of service. Our technical engineers alongside our Data Centre team were engaged. Performed investigations indicated multiple web requests coming in from various IP’s. This impacted services for some Matrix customers hosted in those data centres.

Our teams performed multiple containment actions, that included:

  • Blocking individual IPs on Origin Server
  • Block top 10 worst offending IPs on Border Routers

Above actions promoted recovery at 00:24 GMT on the 2nd of October 2022.

Customer impact

Between 20:54 GMT on the 1st of October 2022 and 00:24 GMT on the 2nd of October 2022, Squiz Edge customers hosted in our ASH and Newbury Data Centre’s may have been unable to access their applications.

Root cause

Starting at 20:54 GMT on the 1st of October 2022, a very large number of different IP addresses from a number of different countries and Internet Service Providers started making 'cache busting' requests. It was identified that these IPs made more than 10000 requests causing a high server load, resulting in degradation of service for our customers.

Mitigation and Follow-up actions

The Squiz Data Centre team has confirmed that there are no further actions required from a Security perspective. Our teams are continuing to closely monitor the current situation but so far we have not seen anything requiring further action. In addition, we are working closely with our Distributed Denial of Service (DDoS) protection provider to ensure their reports are being monitored for any observed anomalies.

Posted Oct 04, 2022 - 22:20 AEDT

Resolved
Services have been restored for our Squiz Edge customers hosted in the ASH and Newbury Data Centre's. We apologise for this degradation of service and thank you for your patience while we worked on the resolution.

A postmortem will be provided via https://status.squiz.cloud
Posted Oct 02, 2022 - 11:03 AEDT
Update
Squiz teams have identified the cause and are performing recovery actions.
Posted Oct 02, 2022 - 10:30 AEDT
Update
The Squiz Data Centre team continues to investigate the degraded Squiz Edge services for customers hosted in our ASH and Newbury Data Centre's. Discussions are ongoing with our external provider.
Posted Oct 02, 2022 - 10:02 AEDT
Identified
The Squiz Data Centre team are engaged with our external provider. In the meanwhile, internal workaround actions are being performed to mitigate the incident.
Posted Oct 02, 2022 - 09:30 AEDT
Update
Ongoing investigations have indicated that the degradation of service is also experienced by Squiz Edge customers hosted in Newbury Data Centre.

The Squiz Data Centre team is running further checks.
Posted Oct 02, 2022 - 08:48 AEDT
Investigating
Squiz monitoring has detected a degradation of service incident that is affecting customers hosted in our ASH Data Centre. Multiple Squiz teams are currently investigating.

A further update will be provided in ~15 minutes.
Posted Oct 02, 2022 - 08:27 AEDT
This incident affected: Squiz Edge.