Major Incident - Funnelback SaaS US
Incident Report for Squiz
Postmortem

Summary

During routine monitoring, Squiz identified operational issues with Funnelback services in the US, leading to search function disruptions and latency for several customers.

Customer impact

A subset of US Customers may have experienced delays in search results and encountered 500 errors when attempting to utilise the Funnelback search function.

Issue and Resolution

Squiz engineers were alerted to errors and timeouts originating from our Squiz hosted Funnelback services in the US. This was isolated to the search sessions feature, which was subject to slow response times or termination due a build up of stored requests.

In response, we disabled the session storing feature and alleviated the database usage. This will not cause any disruption to search traffic.

As part of our standard process we initiated a period of heightened monitoring leading to resolution on May 13th at 17:20 BST

Mitigation

We have added new monitoring checks to flag excess database usage as well as utility scripts to help us debug slow performance in the future. Our Product team is investigating approaches to improve session performance in order to improve overall query performance going forward.

Posted May 16, 2024 - 00:14 AEST

Resolved
After identifying issues with sessions and taking steps to repair sessions database the server performance issues have now been resolved.
Posted May 14, 2024 - 02:34 AEST
Monitoring
Changes have been implemented to the session database which should resolve the performance issues.
We are currently monitoring to confirm.
Posted May 14, 2024 - 02:21 AEST
Identified
We have identified issues with search sessions and are taking steps to address the issue.
Posted May 14, 2024 - 02:00 AEST
Update
We are continuing to investigate performance issues with Squiz hosted Funnelback in the US. Our team is actively troubleshooting server issues.
Posted May 14, 2024 - 01:44 AEST
Update
We are continuing to investigate performance issues with Squiz hosted Funnelback in the US. Other regions are unaffected.
Posted May 14, 2024 - 01:20 AEST
Investigating
Squiz monitoring has detected a degradation of service with Squiz hosted Funnelback.

We are working hard to investigate the route cause of the issue and will provide further updates via https://status.squiz.cloud in 15 minutes, or earlier if the situation or information changes.
Posted May 14, 2024 - 00:47 AEST
This incident affected: Squiz Funnelback Hosted Instances.