Major Incident - Some AU/NZ Customers - 08th March 2023
Incident Report for Squiz
Postmortem

Executive Summary

At ~11:02 AEDT on the 8th of March 2023, Squiz internal monitoring generated SSL alerts for some Australia/New Zealand customers using clients.squiz.net subdomains. Impacted customers may have received an SSL error message upon accessing their site or upon performing a search.

The Squiz Technical Engineering team renewed the expired certificates used by Squiz Edge to communicate with web servers, followed by a restart of Openresty service, promoting recovery at ~11:30 AEDT on the 8th of March 2023.

 

Root Cause

SSL certificates for some Squiz Edge customers using clients.squiz.net subdomains had expired. 

Mitigation and Follow-up Actions

To prevent future recurrences, the Squiz Technical Engineering team will examine and update the procedures and processes involved with these internal certificate renewals.

Posted Mar 14, 2023 - 10:39 AEDT

Resolved
Squiz monitoring detected an issue leading to a degradation of services for some customer endpoints. This service issue has now been resolved.

A postmortem will be provided via https://status.squiz.cloud .
Posted Mar 08, 2023 - 12:07 AEDT
Investigating
Squiz monitoring has detected a degradation of service affecting some customers. Squiz Technical Engineering team is currently investigating.
Posted Mar 08, 2023 - 11:53 AEDT
This incident affected: Squiz Cloud Hosted Instances.